Frame Relay LMI Autosense Lab#02

| Monday, June 21st, 2010 | 2 Comments »

In this lab, we’re going to take a look at autosensing the LMI signaling protocol. As we’ve seen in Lab#01, you need this to be correct in order to bring the link up.

We’ll start with the frame relay switch configuration.

FRAME RELAY SWITCH

RTR-3620#config t
RTR-3620(config)#frame-relay switching
RTR-3620(config)#int s1/1
RTR-3620(config-if)#encapsulation frame-relay

RTR-3620(config-if)#clock rate 64000
RTR-3620(config-if)#frame-relay intf-type dce
RTR-3620(config-if)#end

RTR-3620#sh run int s1/1
Building configuration…

Current configuration : 213 bytes
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
end

Notice what is missing from the show run command? There is nothing indicating what the LMI type is! This is because by default, the LMI type is “cisco”.

RTR-2501

RTR-2501(config)#int s0
RTR-2501(config-if)#ip address 192.1.1.3 255.255.255.0
RTR-2501(config-if)#encapsulation frame-relay

Verification

We check the interface status on the frame relay switch. Below, in bold, you’ll see that the interface is acting as a DCE and the LMI type is “cisco”.

RTR-3620#sh int s1/1
Serial1/1 is up, line protocol is up <— Everything is up/up. This is good. Line and protocol.
Hardware is M4T
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
LMI enq sent  0, LMI stat recvd 0, LMI upd recvd 0
LMI enq recvd 124, LMI stat sent  124, LMI upd sent  0, DCE LMI up
LMI DLCI 1023  LMI type is CISCO  frame relay DCE
Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
Last input 00:00:06, output 00:00:06, output hang never
Last clearing of “show interface” counters 00:20:42
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations  0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
124 packets input, 1612 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
124 packets output, 1780 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
2 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Now to double-confirm, we can also check the RTR-2501 router. Below, you see that the LMI type is “cisco” as well as the router configured as a DTE device.

RTR-2501#sh frame-relay lmi

LMI Statistics for interface Serial0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0             Invalid Prot Disc 0
Invalid dummy Call Ref 0              Invalid Msg Type 0
Invalid Status Message 0              Invalid Lock Shift 0
Invalid Information ID 0              Invalid Report IE Len 0
Invalid Report Request 0              Invalid Keep IE Len 0
Num Status Enq. Sent 145              Num Status msgs Rcvd 144
Num Update Status Rcvd 0              Num Status Timeouts 1

Causing Trouble

Let’s cause some trouble now and enable debugging. We’re going to change the encapsulation to PPP and shutdown the interface.

RTR-2501(config)#int s0
RTR-2501(config-if)#shut

Right away both routers display that the link goes down.

RTR-2501(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
%LINK-5-CHANGED: Interface Serial0, changed state to administratively down

RTR-3620#
%LINK-3-UPDOWN: Interface Serial1/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to down

Before moving onto the debug stage, we run the “show run” command to make sure that encapsulation is now PPP and not FRAME RELAY.

RTR-2501#sh run int s0
!
interface Serial0
ip address 192.1.1.3 255.255.255.0
encapsulation ppp
shutdown
no fair-queue

Debuggin’ Time

We first enable “frame-relay lmi” debugging on both the RTR-2501 and RTR-1720.

RTR-2501#debug frame-relay lmi
Frame Relay LMI debugging is on
Displaying all Frame Relay LMI data

RTR-3620#debug frame-relay lmi int s1/1
Frame Relay LMI debugging is on
Displaying lmi data from interface Serial1/1 only

Now we put set the encapsulation back to FRAME RELAY and unshut the interface.

RTR-2501(config)#int s0
RTR-2501(config-if)#no shut

Both routers now are displaying some LMI exchanges. We’ll start with the RTR-2501, and then show the RTR-3620.

RTR-2501
Serial0(out): StEnq, myseq 1, yourseen 0, DTE up <–direction of the request is OUT the interface.
datagramstart = 0x10007C, datagramsize = 13

FR encap = 0xFCF10309
00 75 01 01 00 03 02 01 00

RTR-3620
Serial1/1(in): StEnq, myseq 0 <–direction of the request from RTR-2501 to this interface.
RT IE 1, length 1, type 0
KA IE 3, length 2, yourseq 1 , myseq 0
Serial1/1(out): Status, myseq 1, yourseen 1, DCE up

RTR-2501
Serial0(in): Status, myseq 1 <–direction of the response from RTR-3620 to this interface.
RT IE 1, length 1, type 0
KA IE 3, length 2, yourseq 1 , myseq 1
PVC IE 0x7 , length 0x6 , dlci 101, status 0x0 , bw 0

What you see above is that the RTR-2501’s LMI request with Serial0(out). And then RTR-3620 receives and then responds back with Serial1/1(in).

Verification….again…

Before we end this lab, we confirm on both interfaces to see what we’ve negotiated the LMI type to be!

RTR-3620#sh frame lmi int s1/1

LMI Statistics for interface Serial1/1 (Frame Relay DCE) LMI TYPE = CISCO
Invalid Unnumbered info 0             Invalid Prot Disc 0
Invalid dummy Call Ref 0              Invalid Msg Type 0
Invalid Status Message 0              Invalid Lock Shift 0
Invalid Information ID 0              Invalid Report IE Len 0
Invalid Report Request 0              Invalid Keep IE Len 0
Num Status Enq. Rcvd 290              Num Status msgs Sent 290
Num Update Status Sent 0              Num St Enq. Timeouts 23

RTR-2501#sh frame lmi

LMI Statistics for interface Serial0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0             Invalid Prot Disc 0
Invalid dummy Call Ref 0              Invalid Msg Type 0
Invalid Status Message 0              Invalid Lock Shift 0
Invalid Information ID 0              Invalid Report IE Len 0
Invalid Report Request 0              Invalid Keep IE Len 0
Num Status Enq. Sent 123              Num Status msgs Rcvd 123
Num Update Status Rcvd 0              Num Status Timeouts 0

Conclusion

It’s always fun to configure interfaces, protocols etc etc, but to view the debugs and see the actual routers exchange info helps you to really see how routers/switches operate. Get used to using SHOW and DEBUG commands. They are going to be vitally important in your Cisco career!

Share